Not getting order updates for one book

Created almost 3 years ago by Nicola Sarjeant with 3 comments
Sort by
(scroll to first comment)
11822672 10153561216304433 2908637650851023738 n Nicola Sarjeant · Reader · edited almost 3 years ago
Thanks for the reply.  I am definitely following the book.  Perhaps it has been a policy change whereby the sales updates only appear when the author has actually written an update?  

Certainly in the past I was getting sales updates in ’Yesterday’s Buzz’ for books I was following when the author hadn’t written an update.  That’s why I was wondering.  

Edit: Actually, yesterday’s Buzz still included a sales update without an author’s personal update, so I guess it isn’t a policy change?
162980 10150347252315626 6077063 n Joseph Terzieva · Author · added almost 3 years ago
Which book are you not receiving updates for? A couple possible options.

When you view the book page at the top by the title does it say you are "following" the book. Even if you have purchased the book, you can opt to not follow the updates.

When was the last time the book sent an update? You can tell be looking in the comments section of the book. Is it possible they have not sent one in a while?

You won’t receive notifications when a book you follow has sold copies, only when the author of that book sends out an update.
11822672 10153561216304433 2908637650851023738 n Nicola Sarjeant · Reader · edited almost 3 years ago · 1 like

I have been receiving the Yesterday’s Buzz email daily.  It shows ’Copies Sold’ and ’New Followers’ for most of the books I have ordered/followed.  However, lately I’m not getting updates for one of the books I’ve ordered (even though I know there have been books sold).  I haven’t seen any updates for this book for some time (maybe a couple of weeks?), although I’m getting updates for that person. 

I would understand if it was just a random allocation of updates if I was following a lot of different books, but I’m not.  Also, another reader  (who has only bought that book) is having the same issue.

Any ideas why this is happening?